Script Management Bandwidth Dengan Simple Queue Parent Mikrotik

Selamat datang kembali di blog BangCopo...

Seperti yang kita tahu mikrotik adalah salah salah satu perangkat router yang digunakan untuk management jaringan, dari sekian banyak fitur yang dimiliki mikrotik salah satunya yang berguna banget dan pasti banyak digubakan adalah management bandwidth.

Ada 2 cara management bandwidth di mikrotik yaitu Simple Queue dan Queue tree. Kali ini saya akan membahas sedikit tentang Simple Queue. Simple queue sendiri banyak sekali yang manfaatkan untuk management bandwidth karena memang Simple Queue ini relatif lebih mudah dimengerti daripada Queue tree yang membutuhkan pengetahuan lebih mendalam tentang jaringan.

Syarat utama menggunakan Simple Queue adalah harus mengetahui IP Address target yang akan di limit bandwith nya. Caranya dengan membuka Queue pada winbox kemudian pada tab Simple Queue klik tanda "+". Kemudian beri nama sesuai kebutuhan dan masukkan IP Address yang akan dilimit dan masukkan juga berapa limitasi yang dibutuhkan. Lihat gambar agar lebih jelas.

simple queue mikrotik
Simple Queue
Nah yang jadi masalah adalah dalam jaringan dengan skala yang lebih besar tentu kita akan kesulitan untuk memasukkan satu-persatu IP Address yang akan di limit, seperti jika menggunakan subnet /24 maka setidaknya akan ada 254 IP yang bisa digunakan. Cara yang paling mudah dengan menggunakan script looping atau pengulangan.
Seperti contoh kasus dalam sebuah perusahaan:
  • Total bandwidth yang dimiliki adalah 50Mbps yang akan digunakan oleh 5 Prioritas 1 seperti direktur, manager dll, 30 User prioritas 2 dan sisanya akan digunakan untuk Wifi yang tersambung.
  • IP yang digunakan adalah 192.168.1.0/24
  • Dengan perencanaan bandwidth 5 Prioritas 1 menggunakan bandwidth 5Mbps pada IP Address 192.168.1.10-192.168.1.15
  • 30 User prioritas 2 menggunakan 2Mbps pada IP Address 192.168.1.16-192.168.1.45 
  • Sisanya akan digunakan oleh pengguna wifi dengan speed per IP 512k pada IP Address 192.168.1.45-192.168.1.254.
Berikut ini adalah langkah-langkah konfigurasinya :

1. Membuat Parent
Langkah pertama yang harus dilakukan adalah membuat Parent terlebih dahulu dengan total bandwidth yang dimiliki yaitu 50Mbps. Dengan cara pada tab Simple Queue masukkan nama "Total_bandwidth" target address dikosongkan saja. Kemudian pada kolom max limit isi target upload dan downloadnya 50Mbps.
membuat parent simple queue mikrotik
Membuat Parent

2. Script Simple Queue
Langkah selanjutnya adalah membuat script untuk user 5 prioritas 1, cara memasukkan scriptnya di menu System - Script.
membuat script simple queue mikrotik
Membuat Script


scriptnya seperti berikut :

  • :for x from 10 to 15 do={/queue simple add name="Priortas-$x" max-limit=5M/5M target="192.168.1.$x" parent=Total_bandwidth interface=ether2 priority=1}

Simpan dengan nama userprioritas1.
script simple queue with parent mikrotik
Script 1

Selanjutnya script untuk 30 user prioritas 2

  • :for x from 16 to 45 do={/queue simple add name="User-$x" max-limit=2M/2M target="192.168.1.$x" parent=Total_bandwidth interface=ether2 priority=2}

Simpan dengan nama userprioritas2.
script simple queue with parent mikrotik
Script 2

Dan yang terakhir adalah sisa bandwidth yang akan digunakan oleh pengguna wifi.

  • :for x from 46 to 254 do={/queue simple add name="Userwifi-$x" max-limit=512k/512k target="192.168.1.$x" parent=Total_bandwidth interface=ether2 priority=8}

simpan dengan nama userwifi.
script simple queue with parent mikrotik
Script 3
3. Jalankan Script
Juka sudah disimpan semua jalankan script satu persatu mulai dari script userprioritas1 sampai userwifi, maka hasilnya akan seperti berikut.
run script simple queue with parent mikrotik
Run Script
Semua Simple Queue yang berhasil dibuat oleh script otomatis akan langsung masuk ke Parent Total_bandwidth. Dan juga priority masing-masing user sesuai dengan script yang sudah dibuat.

hasil script simple queue with parent mikrotik
Hasil Script
Demikian artikel dari saya semoga tulisan ini bermanfaat buat kalian yang lagi membutuhkan. Kalau mungkin ada pertanyaan silahkan di tulis dikomentar.


Bang Copo
Bang Copo Hanya seorang buruh pabrik yang menyukai perkembangan teknologi

1 komentar untuk "Script Management Bandwidth Dengan Simple Queue Parent Mikrotik"

  1. klo mau edit simple-queue menddunakan script, perintahnya gimana ya.. misal saya mau edit nomor 18, maka perintahnya que simple edit number=18 value-name, lalu selanjutnya gimana ya, misal mau merubah max-limit dari 1M/2M menjadi 2M/5M, qunanya script ini untuk merubah otomatis menggunakan scheduler, keutamaanya jika di jam malam bandwidth melimpah, maka salah satu client ingin saya perbesar bandwidthnya, jika menggunakan schaduler kan enak, udah otomatis berubah di jam2 tertentu. terimakasih

    BalasHapus