Monitoring Hotspot Mikrotik Dengan Bot Telegram

Sebenarnya cara ini sudah lama dan sudah banyak yang menggunakan, tapi berhubung saya baru saja memanfaatkannya mangkannya baru sekarang saya tulis disini,hehehe...

Selamat datang kembali kawan-kawan di blog saya kali ini saya akan membahas bagaimana cara agar bisa me-Monitoring Hotspot Mikrotik dengan memanfaatkan Bot pada Telegram. Cara ini akan sangat bermanfaat ketika kalian para pengusaha Hotspot yang tidak selalu stand by di tempat, karena dengan cara ini kalian akan selalu mendapatkan notifikasi ketika ada user Login, user Logout jumlah total user yang online ada berapa, dan juga notifikasi ketika ada salah satu jaringan yang mati/down.
monotiring user hostpot dengan telegram bangcopo.com
Monitoring User

Langsung saja pembahasaannya yang kerena yang akan membarikan notifikasi itu adalah Bot maka dari itu kalian harus membuat Bot terlebih dahulu ada banyak artikel di google silahkan searching sendiri. Setelah pembuatan Bot sudah selesai dan dan simpan Token dan Chat Id dari bot tersebut karena ini yang akan kita masukkan ke dalam script mikrotik nanti pada pembahasan selanjutnya.

A. Script Monitoring User Hotspot.

Pada mikrotik buka menu IP - Hotspot dan klik pada tab User Profile dan buka profile mana yang akan di monitoring. Dan Masukkan Script di bawah ini pada On Login

:local useraktif [/ip hotspot active print count-only];
/tool fetch url="https://api.telegram.org/botToken_Bot_Telegram_Anda/sendMessage?chat_id=Chat_ID_Bot_Anda&text=User $user IP $address Masuk Total : $useraktif" keep-result=no

Dan masukkan script dibawah ini untuk On Logout

:local useraktif [/ip hotspot active print count-only];
/tool fetch url="https://api.telegram.org/botToken_Bot_Telegram_Anda/sendMessage?chat_id=Chat_ID_Bot_Anda&text=User $user IP $address KeluarTotal : $useraktif" keep-result=no

Jangan lupa untuk memasukkan Token dan Chat Id Bot Telegram kalian dan untuk pesan nofifikasi yang akan di kirimkan bisa kalian ganti sesuai selera.


Script monitoring user hotspot dengan telegram bangcopo.com
Script Monitoring User



B. Script Monitoring Jaringan

Bot Telegram juga bisa digunakan untuk memonotoring jaringan dengan menggabungkan dengan fitur mikrotik yaitu Netwatch pada menu Tools - Netwatch.

Buka netwatch pada mikrotik dan buka IP yang akan dimonitoring seperti contoh di kasus saya, saya akan memonitoring AP yang saya gunakan untuk Hotspot pada IP 192.168.2.12

pada Tab UP masukkan Script di bawah ini.

tool fetch url="https://api.telegram.org/botToken_Bot_Telegram_Anda/sendMessage?chat_id=Chat_ID_Bot_Anda&text=AP 1 On bos" keep-result=no

Scrip up mikrotik netwatch bot telegram bangcopo.com
Script Up

dan pada Tab Down masukkan script di bawah ini.

tool fetch url="https://api.telegram.org/botToken_Bot_Telegram_Anda/sendMessage?chat_id=Chat_ID_Bot_Anda&text=AP1 Tiwas bos" keep-result=no
Scrip mikrotik netwatch bot telegram bangcopo.com
Script Down

Setelah selesai dan simpan konfigurasi tersebut dan hasilnya akan seperti ini.

hasil monitoring hotstpot dengan bot telegram bangcopo.com
Hasil Monitoring Pada Telegram Mobile
 

hasil monitoring hotstpot dengan bot telegram bangcopo.com
Hasil Monitoring Pada Telegram Web

Demikian tulisan saya ini semoga bisa bermanfaat untuk para pembaca. Terimakasih.

Bang Copo
Bang Copo Hanya seorang buruh pabrik yang menyukai perkembangan teknologi

4 komentar untuk "Monitoring Hotspot Mikrotik Dengan Bot Telegram"

  1. maksud chat id yang mana om ? saya udah coba cara di atas tapi ga ada replay ke akun bot.
    mohon bimbingan nya, terima kasih

    BalasHapus
    Balasan
    1. Duh maap baru baru bisa balas om, jarang buka blog...
      Chat id didapat waktu buat bot om.. ada token bot ada chat id

      Hapus
  2. di screnshoot https://1.bp.blogspot.com/-GASZ8cdHCjs/Xk4gS-dXoNI/AAAAAAAAAVs/vl8FvK5u2R4qyp9SgxTTGA24UuKoJ2_OwCPcBGAYYCw/s1600/1582178373331072-0.png
    ada yang muncul Mac Address dan ada yg tidak, bagaimana cara memunculkan selalu mac address user yang login/keluar ?

    BalasHapus
    Balasan
    1. itu mac address yang muncul dari user trial om...
      kalau mau munculkan mac tinggal tambahi "$mac" pada script..

      Hapus